Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Having trouble with a newly setup server's ftp.

Basically, I can ftp find with no errors, I have successfully sent over smaller files, but at about 80Kb+ the file won't send.

First, any operations tells me

229 Entering Extended Passive Mode (|||61473|)

Is this a default? I haven't had this issue on other servers I've configured. If this is the issue, how can I explicitly set it to Active mode?

The file begins to transfer...ETA at about ten minutes..will get to 15% or so and the next time I check my console I receive

229 Entering Extended Passive Mode (|||30889|).
150 Ok to send data.
0% |                                   |    -1        0.00 KiB/s    --:-- ETA
share|improve this question

migrated from stackoverflow.com Jun 5 '12 at 15:25

This question came from our site for professional and enthusiast programmers.

add comment

1 Answer

Passive mode is selected by the client. Take a look at the command-line help for whatever FTP client you are using, if you want to disable passive mode.

Looking at the second snippet, it does not seem like your client is receiving any data at all. A common problem with passive mode is firewalls and other port translating devices, that do not understand the port numbers embedded in FTP protocol chatter. You can either try avoiding passive mode, or locating the hop that causes the problem.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.