Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

This seems similar: EXT4 "No space left on device (28)" incorrect but there is no explanation

I created an ext4 filesystem on a RAID 1 array with:

mke2fs -t ext4 -T small /dev/md0

tune2fs -l >> http://pastebin.com/P5eKXmgC

tried this too:

mke2fs -t ext4 -b 1024 /dev/md0

tune2fs -l >> http://pastebin.com/ujLtE95L

Copying a single directory with many tiny files I get:

cp: cannot create regular file `/mnt/storage_temp/pics/pic3412.jpg': No space left on device

space used 5%

inodes used 1%

I manually tried:

cp /source/test1.jpg /mnt/storage_temp/pics/test1.jpg --- error
cp /source/test1.jpg /mnt/storage_temp/pics/test2.jpg --- ERROR
cp /source/test1.jpg /mnt/storage_temp/pics/test3.jpg --- no error

Notes: RAID 1 disks are error free. I tried mv instead of cp and got the same thing. I tried omitting -T small with no effect

Can somebody help me understand this magic?

share|improve this question
1  
Please correct your question for internal consistency and don't just blindly copy from another forum. –  MikeyB Jun 5 '12 at 21:15
    
The site you are looking for is google. –  PenguinCoder Jun 6 '12 at 1:10
    
@MikeyB : Where did he copy this question from? –  Stefan Lasiewski Jun 6 '12 at 1:16
    
please let me know what's unclear, i'll try to improve it. it's irrelevant where else i might have posted this question. what matters is that this might be the only place with the answer if you can actually help. –  user1434058 Jun 6 '12 at 1:33
    
Please provide the output of sudo tune2fs -l /dev/md0. –  mgorven Jun 6 '12 at 4:35
show 1 more comment

1 Answer

How small is that partition? According to man mke2fs, the -T small gets automatically used if the partition size is between 3 - 512 megabytes. Is the partition that small? If not, do you really need that mke2fs option?

share|improve this answer
    
2TB drive, single partition, the "-T small" was intended to get the 1024 block size but i also tried "-b 1024" instead and the result was the same –  user1434058 Jun 6 '12 at 12:48
    
So, my another question: do you have a rationale for that -T small? –  Janne Pikkarainen Jun 6 '12 at 12:50
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.