Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I was setting up some new RHEL machines to monitor with our Opsview Community 20120424 server (which is based on 3.x) and discovered that the Opsview yum repository no longer has the 3.x opsview-agent, only the 4.0 agent.

Given that 4.0 is a significant break from 3.x, I am dubious as to why they would have completely removed the old agent if it were not compatible, given that most IT departments aren't going to just upgrade the core monitoring server to 4.0 just so they can install new clients.

Does anyone know if the 4.0 agent is compatible with the 3.x server, or if I need to install an older version?

FYI, an older version is available at linux.mirrors.es.net, but I would rather just install the latest version if it works.

share|improve this question
add comment

1 Answer 1

up vote 1 down vote accepted

The Opsview agent is just the NRPE daemon. As long as Opsview is "just" Nagios with sugar on top it will be compatible. Have a look at the init script, it simply starts NRPE.

share|improve this answer
    
Thanks for responding! I actually just tried it a while back and it worked, and I forgot I posted the question. It's good to know why it works, though. –  Chris R. Donnelly Sep 10 '12 at 15:17
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.