Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I want to install mailman (just to use it's mail archiving feature) but Ubuntu wants to pull down a load of extra dependencies.

sudo apt-get install mailman 
Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following extra packages will be installed:
  apache2 apache2-mpm-worker apache2.2-common
Suggested packages:
  apache2-doc apache2-suexec apache2-suexec-custom spamassassin lynx listadmin

Is there any way to mark those packages ( apache2 apache2-mpm-worker apache2.2-common ) as never to be installed? This is not 2002 ;)

share|improve this question

1 Answer 1

up vote 4 down vote accepted

Mailman depends on either apache2 or the httpd metapackage, so pick a webserver that fancies you and provides httpd.

Edit: You can get a list of packages providing httpd with the command aptitude search '~Phttpd' and in case that you really don't want any web server installed (and risk a broken system), you could construct a dummy package with the help of the tools in the equivs package.

share|improve this answer
    
Didn't realize I hadn't installed lighttpd. What are these tools in the equivs package ( got a link? ). –  Bryan Hunt Jun 6 '12 at 8:31

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.