Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am doing nominatim installation on my server. I run the following command

./utils/setup.php --osm-file /usr/share/osm2pgsql/planetfile/planet-latest.osm.pbf --all

to import the pbf file and Few tables are imported successfully and finally at the end of the script I got the following error:

/usr/share/osm2pgsql/osm2pgsql -lSc -O gazetteer --hstore -C 24591 -d nominatim /usr/share/osm2pgsql/planetfile/planet-latest.osm.pbfUsing projection SRS 4326 (Latlong)
NOTICE:  table "place" does not exist, skipping
NOTICE:  type "keyvalue" does not exist, skipping
NOTICE:  type "wordscore" does not exist, skipping
NOTICE:  type "stringlanguagetype" does not exist, skipping
NOTICE:  type "keyvaluetype" does not exist, skipping
NOTICE:  function get_connected_ways(pg_catalog.int4[]) does not exist, skipping
Allocating memory for dense node cache
Allocating dense node cache in one big chunk
Allocating memory for sparse node cache
Sharing dense sparse
Node-cache: cache=24591MB, maxblocks=3147649*8192, allocation method=3
Mid: Ram, scale=10000000

Reading in file: /usr/share/osm2pgsql/planetfile/planet-latest.osm.pbf
Entity: line 1: parser error : Document is empty

^
/usr/share/osm2pgsql/planetfile/planet-latest.osm.pbf : failed to parse
Error occurred, cleaning up
osm2pgsql SVN version 0.80.0 (32bit id space)

DB Error: no such table

Please suggest what can I do to solve this issue. Give me any solution. Thanks in advance.

share|improve this question
    
The logs imply that /usr/share/osm2pgsql/planetfile/planet-latest.osm.pbf is empty... is it? –  mgorven Jun 7 '12 at 5:58
    
No file is not empty. planet file is 16GB and I have also tried with german.pbf it is 1.2GB. And I am facing the same error with both the files... Is it any memory related issue? What is the solution? –  Ravi Kotwani Jun 13 '12 at 5:47

1 Answer 1

You could try

apt-get isntall libprotobuf-c0-dev libprotobuf-dev protobuf-c-compiler protobuf-compiler
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.