Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have some databases on my shared web server. It was all fine around 45 days back when my website is shifted to another server, all my data is shifted including databases. Now I cannot connect to my MySQL databases via external software (Visual Studio, Workbench etc). I can successfully connect to my databases via MyPHPAdmin provided to me via cpanel. The desktop applications are showing the following errors:

MySQL WorkbenchMicrosoft Visual Studio 2008

By reading some other questions on internet, I come to the point that it might be the firewall problem on webserver, it might block MySql default port 3306. How can I go into the firewall of my webserver and allow my port, (if it is a real problem)? I am using the default port of MySQL databases ie. 3306, I have already made my databases access globally by putting '%' in the remote access IP address.

share|improve this question
    
If it's really a "shared web server", then access to MySQL is usually forbidden for external connections for security and performance purposes. Plus, with shared web server the MySQL database will usually (well, in most cases) be located on separate server specially optimized for DB. I strongly suggest to contact your hosting company and ask for clarification if such connection is possible from outside network. very likely they have just disabled such possibility (firewall and/or mysql config) –  LazyOne Jun 6 '12 at 13:18

1 Answer 1

Well depending on your contract and shared webserver you might be prohibited to access mysql from out side.

Ask the suport guys to add an entry to the firewall so that you can access it from outside.They will most likely add it or explain why they can't . i won't ask them for clarification as they might dodge that.

Hope this helps.

share|improve this answer
    
@ - Alex H But I was accessing my databases before the transfer of my website, when I asked the support guy to do so, he told me that he is not concenered with the databases. There is an other way to do so? –  Farid-ur-Rahman Jun 6 '12 at 18:58
    
That would be the most straight - forward way to do it . If you have access to ssh you can always try to add an entry in the firewall for mysql port . Please have a look here , it has multiple examples ubuntu-commands.blogspot.ro/2008/11/… . –  Alex H Jun 7 '12 at 6:01
    
I tried SSH shell, it shows that "Shell access is not enabled on your account", What should I do? –  Farid-ur-Rahman Jun 8 '12 at 8:07
    
Contact the support for your VPS :) and ask the modifications that you want from their side . –  Alex H Jun 8 '12 at 8:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.