Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I am trying to install Linux Mint 13 on my VirtualBox. I created a new VB hard drive with a dynamically allocated size of 8GB (I have tried with fixed size as well). I have tried installing Linux Mint 13 64-bit and 32-bit and every time during install, it sees the hard drive size as 8.6GB (bigger than I made the drive to be) and if I proceed, after install it only sees the drive size as 4.5GB and of course fills up very quickly.

I am on a Windows 7 64-bit host OS with 8GB of memory (4GB which I have been allocating to the guest). I didn't have any issues with install. Everything goes smoothly until the drive size is shown in my guest.

What am I doing wrong? Should I try an earlier version (I have already downloaded both architectures of 13)?

share|improve this question
Boot with a bootable disc image like Ubuntu for example or RIP and run gparted and see what it reports as the disk size. And/or any utility of choice to see what the drive image size is being reported as. – Bart Silverstrim Jun 6 '12 at 17:14
GParted says 8GB, but even after creating a partition table on the disk, the installer still sees it as 8.6GB....bizarre.....still stumped – Benny Jun 6 '12 at 17:24
What does it say the partition table type and filesystem are? – Bart Silverstrim Jun 6 '12 at 17:25

Turns out it was pretty simple. I've never allocated this much memory to a VM before so it turns out that since I had 4GB of memory and told mint to take care of the partitioning itself, it used 4GB for the swap hence my 8GB turning into 4GB. I made a new HD and allocated 12GB and now I have 8GB available after install.

Side Note Still baffles me that Mint recognizes the drive as 8.6GB when it's really only 8GB, but nonetheless I got up and running.

share|improve this answer

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.