Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm using FreeSSH on my server and Putty on my client.

I'm trying to make a port (3333) on my server connect to my local PC. This way my PC port is visible to the outside.

However, when I look with netstat -an on the server, I see that there is a connection on: 127.0.0.1:3333 instead of on 0.0.0.0:3333 (or even my specific ip).

This makes the port unreachable from the outside. Is there any way/setting to make it bind to the correct network card (or any network)

share|improve this question

2 Answers 2

I found it. In Putty, under Connection->SSH->tunnels, you have to both check both the checkmarks:

 - local ports accept connections from other hosts
 - remote ports do the same

I also had to restart FreeSSH. But then we I reconnected with putty it was bound to: 0.0.0.0:3333

share|improve this answer

Normally applications have a configuration setting for that. OpenSSH has:

ListenAddress 0.0.0.0
share|improve this answer
    
Although, I think I misunderstand your question, reading it again. Could you clarify? Are you setting up a tunnel? –  Halfgaar Jun 7 '12 at 13:41
    
yes I'm setting up a tunnel. –  reinier Jun 7 '12 at 13:46

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.