Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have 4 nodes to the internet:

Internet <--> Node A <--> Node B <--> Node C <--> Node D

Node A: main gateway, manage internet
Node B: gateway/tunnel to node C
Node C: gateway/tunnel to node B
Node D: FreeNAS server

Between B and C is a semi-private network. Default route on Node C is via the tunnel.

Can ping:

A: Internet, A, B, C, D
B: Internet, A, B, C, D
C: B, C, D
D: Internet, A, B, C, D

I really don't get it...

edit

traceroute 8.8.8.8
traceroute to 8.8.8.8 (8.8.8.8), 64 hops max, 52 byte packets
 1  10.20.1.1 (10.20.1.1)  0.959 ms  0.753 ms  0.535 ms
 2  10.20.200.1 (10.20.200.1)  4.993 ms  5.010 ms  4.804 ms
 3  10.20.2.1 (10.20.2.1)  5.152 ms  5.218 ms  5.046 ms
 4  modemcable233.11-37-24.static.videotron.ca (24.37.11.233)  5.638 ms  5.684 ms  5.645 ms

Traceroute from D to internet:
1: Node C
2: Node B (tunnel ip)
3: Node A
4: Internet

share|improve this question
1  
Check the default gateway on C –  Tom O'Connor Jun 7 '12 at 13:40
    
default GW on C is the IP of Node B's tunnel0 interface. D can ping internet via C whitout issue. –  Sirber Jun 7 '12 at 13:51

2 Answers 2

up vote 0 down vote accepted

Node A was missing a route to the tunnel between B and C.

Pings went from C->B->A->Internet->Internet

Sorry :(

share|improve this answer

probably the gateway on C.

netstat -nr will show you what gateways are in the route table.

you should see

0.0.0.0 <gatewayaddress>

If it is not there, then add it into the Ethernet adapter settings.

share|improve this answer
    
it's there: 0.0.0.0 10.20.200.1 0.0.0.0 UG 0 0 0 tunnel0 –  Sirber Jun 7 '12 at 13:52
    
if that is your correct gateway then make sure you have the nameservers setup properly. Try pinging the google dns servers, but the ip ping 8.8.8.8. if the ip pings, then it is probably no dns being picked up. –  Sc0rian Jun 7 '12 at 13:57

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.