Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a number of CentOS 5 servers which use 3ware RAID controllers.

These servers are bugging my team with messages about minor temperature changes, like this:

Jun  8 12:32:39 HOST smartd[1231]: Device: /dev/twa0 [3ware_disk_01], SMART Usage Attribute: 194 Temperature_Celsius changed from 119 to 118 
Jun  8 12:32:39 HOST smartd[1231]: Device: /dev/twa0 [3ware_disk_03], SMART Usage Attribute: 194 Temperature_Celsius changed from 122 to 121 

How can I suppress these messages?

According to man smartd.conf :

To disable any of the 3 reports, set the corresponding limit to 0. Trailing zero arguments may be omitted. By default, all temperature reports are disabled (´-W 0´).

On my systems, smartd is reporting about temperature changes by default.

I tried a manual approach. In /etc/smartd.conf, I have the following:

/dev/twa0 -d 3ware,1 -a -W 0
/dev/twa0 -d 3ware,3 -a -W 0

But this still does not suppress the messages.

Since these messages show up in /var/log/messages, LogWatch is sending unnecessary emails every night.

share|improve this question
1  
Um... before you go charging down the path of shutting up the alarm, have you verified that your disks are not operating at these temperatures? If you disks are really operating at 100+ degrees celsius you have a very serious problem that needs to be addressed (and if they're not you should be looking for info on calibrating the sensor, not disabling the alarm...) –  voretaq7 Jun 8 '12 at 20:16
    
If you're using logwatch, why not add a filter to logwatch filter those messages? I don't have a moment to compose a full proper reply, but the recipe to add to logwatch wouldn't be all that difficult ... –  Jason Jun 8 '12 at 20:36
1  
FYI, the disks are not at 119C. I can touch them without getting burned :) tw_cli shows them at about 30C. –  Stefan Lasiewski Jun 8 '12 at 21:00
    
And it seems that I am getting bitten by this problem: Smartmontools FAQ: Why is my disk temperature s reported by smartd as 150 Celsius? –  Stefan Lasiewski Jun 8 '12 at 22:10

1 Answer 1

up vote 3 down vote accepted

OK, since we've established that your disks are not melting themselves because you can touch them, I'd say Jason has the right idea with tweaking LogWatch.
It's been a while since I've looked at LogWatch (I think it's pretty lousy and usually disable it), but you can definitely disable the temperature alarms using ignore.conf (there's some info about that in this question, as well as in the LogWatch documentation).


A better solution would be to suss out exactly what the reported temperature value means -- Apparently SMART temperature attributes aren't well defined, and even the smartctl man page says unflattering things about the variability among vendors vendors' implementations:

The conversion from Raw value to a quantity with physical units is not specified by the SMART standard. In most cases, the values printed by smartctl are sensible. For example the temperature Attribute generally has its raw value equal to the temperature in Celsius. However in some cases vendors use unusual conventions. For example the Hitachi disk on my laptop reports its power-on hours in minutes, not hours. Some IBM disks track three temperatures rather than one, in their raw values. And so on.

If you contact your HD vendor they may be able to give you some insight into what their drives are returning for the temperature parameter, and you might be able to teach LogWatch when to raise an alarm (or leave LogWatch configured to ignore the mesaages and implement a smarter monitoring system to look for actual trouble conditions).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.