Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've followed this but when I run:-

     #swapon /swapfile1

I get::-

     swapon: /swapfile1: swapon failed: Operation not permitted

The system is extremely slow with 1GB of RAM trying to run GUI + applications + FreeNX server. Any help is highly appreciated.

share|improve this question
    
Is this a physical or virtual host? If virtual, what kind of virtualisation is in use? –  Jay Jun 10 '12 at 12:31
    
Virtualisation is open-vz –  wajed Jun 10 '12 at 12:47

2 Answers 2

up vote 7 down vote accepted

Swapfiles are only supported on some openvz setups, and disabled on purpose by some admins so you cant use up much more resources than you've been alocated. You probably need to upgrade your vps.

share|improve this answer

Did you run that as the root user? Or try sudo swapon /swapfile1? . Sounds like you need more RAM (-:

share|improve this answer
    
Yes all executed/issued under root –  wajed Jun 10 '12 at 12:47

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.