Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've just installed Jenkins-CI on Ubuntu 11.10 as according to the instructions found here, However the service fails to start. The error log shows this:

Running from: /usr/share/jenkins/jenkins.war
10 Jun 2012 16:24:06 winstone.Logger logInternal
INFO: Beginning extraction from war file
10 Jun 2012 16:24:10 hudson.WebAppMain contextInitialized
SEVERE: Failed to initialize Jenkins
java.lang.ExceptionInInitializerError

The entire error log can be found on this pastebin

I've tried looking for similar errors but I can't find anything. Any ideas would be appreciated.

share|improve this question
    
The instructions work for me. Did you have another implementation of Java installed beforehand? –  Jasper van den Bosch Jun 10 '12 at 18:59
add comment

1 Answer

up vote 0 down vote accepted

Fixed it myself - apt-get uninstall openjdk-6-jre openjdk6-jdk and reinstalling seemed to fix the problem. Not sure why as they were up to date in the first place. Maybe some dependencies were broken.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.