Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

following configuration:

Ubuntu 10.04 Server, 2 NICs:
- eth0 192.168.1.215/24, Default GW: 192.168.1.250
- eth1 192.168.3.225/24

Both are connected to the same router (Funkwerk Bintec R3000).

The router can (via inbuilt diagnostics) ping both IPs successfully.

When both NICs in the server are online, from my local PC (IP is 192.168.1.14/24), I can only ping eth0, but not eth1.

But: when eth0 is disabled on the ubuntu-box, I suddenly can ping eth1!

Now the question: how can I make the ubuntu-machine respond to pings on eth0 and eth1?!

Thanks a lot!

Edit: Command-Outputs

ip addr show

# ip addr show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    inet6 ::1/128 scope host
       valid_lft forever preferred_lft forever
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ether 00:0c:29:db:2a:22 brd ff:ff:ff:ff:ff:ff
    inet 192.168.1.215/24 brd 192.168.1.255 scope global eth0
    inet6 fe80::20c:29ff:fedb:2a22/64 scope link
       valid_lft forever preferred_lft forever
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP qlen 1000
    link/ether 00:0c:29:db:2a:2c brd ff:ff:ff:ff:ff:ff
    inet 192.168.3.226/24 brd 192.168.3.255 scope global eth1
    inet6 fe80::20c:29ff:fedb:2a2c/64 scope link
       valid_lft forever preferred_lft forever

ip link show

# ip link show
1: lo: <LOOPBACK,UP,LOWER_UP> mtu 16436 qdisc noqueue state UNKNOWN
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ether 00:0c:29:db:2a:22 brd ff:ff:ff:ff:ff:ff
3: eth1: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UNKNOWN qlen 1000
    link/ether 00:0c:29:db:2a:2c brd ff:ff:ff:ff:ff:ff

route -n

# route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
192.168.3.0     0.0.0.0         255.255.255.0   U     0      0        0 eth1
192.168.1.0     0.0.0.0         255.255.255.0   U     0      0        0 eth0
0.0.0.0         192.168.1.250   0.0.0.0         UG    100    0        0 eth0

arp -an

# arp -an
? (192.168.1.200) at 00:0c:29:2d:c6:3b [ether] on eth0
? (192.168.1.222) at 00:0c:29:e9:a4:e5 [ether] on eth0
? (192.168.1.250) at 00:a0:f9:02:4e:01 [ether] on eth0
? (192.168.1.70) at 00:0c:29:a1:21:87 [ether] on eth0
? (192.168.3.250) at 00:a0:f9:02:4e:03 [ether] on eth1
? (192.168.3.201) at 00:0c:29:bb:56:8f [ether] on eth1
? (192.168.1.192) at 00:0c:29:45:6f:46 [ether] on eth0
? (192.168.1.14) at 00:26:18:87:89:cf [ether] on eth0
? (192.168.1.105) at 00:0c:29:4c:8a:30 [ether] on eth0
share|improve this question
    
Please post the following from your Ubuntu server: ip addr show, ip link show, route -n, arp -an, finally are these two ubuntu interfaces in different vlans or the same vlan? –  Mike Pennington Jun 11 '12 at 21:02
    
I've updated my question with the requested information. –  Sascha Jun 12 '12 at 5:24
    
Nobody has an Idea? :-( –  Sascha Jun 17 '12 at 8:12
add comment

2 Answers

Your local PC is able to ping the Server as it is in the same subnet as the server.

eth0 is in the 192.168.1.0 to 192.168.1.255 subnetwork

eth1 is in the 192.168.3.0 to 192.168.3.255 subnetwork

Your local PC is in the same subnet as eth0, That is why you are able to ping eth0 not eth1

share|improve this answer
    
I can ping eth1 - but only when eth0 is disabled. –  Sascha Jun 11 '12 at 20:44
    
Is your switch running STP? –  parim Jun 12 '12 at 18:12
    
No, no STP, it's a pretty simple switch without candy. –  Sascha Jun 13 '12 at 5:35
add comment

Please use these settings to evaluate whether you're being bitten by the infamous linux rp_filter:

echo 0 > /proc/sys/net/ipv4/conf/eth0/rp_filter   ## I think you'll only need this
echo 0 > /proc/sys/net/ipv4/conf/eth1/rp_filter   ## Just in case...

Assuming this works, I will follow up with a better long-term configuration.

share|improve this answer
    
Sorry, didn't help.Can still only ping eth0, not eth1. –  Sascha Jun 18 '12 at 14:39
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.