Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have 5 HDDs, /dev/sd[abcde]. After reboot my system volume is sometimes /dev/sda and sometimes /dev/sde.

How can I fix this so that's always the same?

share|improve this question
    
Any detail on the hardware? If this problem persists, look into mounting devices by UUID –  thinice Jun 11 '12 at 20:15
    
What detail do you need? There are 4x 2TB disc and 1x 250 GB running on Debian 6. Mounting by UUID is already enabled but its annoying. –  R.S. Jun 11 '12 at 20:17
    
Ignore the symbolic label and use a UUID or a filesystem you define. –  Zoredache Jun 11 '12 at 20:34
    
My problem is that all my system partitions are mounted by UUID - fine. The other disks should become a Raid-Z - therefore no UUID exists since there is no ext partition on it. –  R.S. Jun 11 '12 at 20:42
    
The disks are all internal SATA disks on the same controller? –  Nils Jun 11 '12 at 21:26

1 Answer 1

You should consider using e2label (for example, this tutorial is quite good).

This way, you can label your devices such as boot, backup, apps and mount based on these labels (so it won't matter which order you plug your drives in, or what order they appear to be detected in).

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.