Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

On an android device, I am connecting to a remote network using openvpn for performing service discovery.

  1. WORKING CASE: After the device is camped on 3g/4g and after connecting to remote network by openvpn, when the zeroconf browser is launched, I can see the mdns query packets being send through the tap0 interface resulting into rendering of services on the browser.

From the tcpdump captured on the device, I can see that the mdns query packets are send to tap0 interface.

tap0 ip: 192.168.11.200

Route table information:
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
76.26.112.234   10.179.240.1    255.255.255.255 UGH   0      0        0 pdpbr1
10.179.240.1    *               255.255.255.255 UH    0      0        0 pdpbr1
32.1.72.136     *               255.255.255.255 UH    0      0        0 pdpbr0
10.179.240.0    *               255.255.255.0   U     0      0        0 pdpbr1
192.168.11.0    *               255.255.255.0   U     0      0        0 tap0
default         192.168.11.1    0.0.0.0         UG    0      0        0 tap0
  1. NOT WORKING CASE: However, after switching on the wifi and connecting it to remote network, when the zeroconf browser is launched, instead of sending the mdns query packets to tap0 interface; these packets are being send to eth0 interface due to which we cannot see the services.

From the tcpdump captured on the device, I can see that mdns query packets are send to eth0 interface.

tap0 ip: 192.168.11.200
eth0 ip: 192.168.43.230

route table information:
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
76.26.112.234   192.168.43.1    255.255.255.255 UGH   0      0        0 eth0
32.1.72.136     *               255.255.255.255 UH    0      0        0 pdpbr0
192.168.11.0    *               255.255.255.0   U     0      0        0 tap0
192.168.43.0    *               255.255.255.0   U     0      0        0 eth0
default         192.168.11.1    0.0.0.0         UG    0      0        0 tap0

In the above case, even though there is a default route for tap0, all the multicast packets are being routed through eth0. How is this possible?

Has anyone observed a similar problem? It would be really helpful if you can help us to discover services through zeroconf browser after the device is connected to remote network via openvpn through wifi.

share|improve this question
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.