Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to mount a loopback device on my ext4 formatted ssd drive. I get these errors when I reboot on Linux kernel 2.6.38.8

Buffer I/O error on device loop1, logical block 0

Here is what I do:

# dd if=/dev/zero of=/mnt/s/lodev bs=4096 count=250000
# mkfs.ext4 /mnt/s/lodev
# mount -n -o loop,rw /mnt/s/lodev /mnt/test

The loopback mount is successful, but on reboot I get errors as mentioned above. Even mouting with 'sync','data=writeback' does not help.

I tried to losetup a device, but see the same behavior. I also reformatted the base device and created the loopback device and mounted as above, I still see these errors. I do not see them when I format them as vfat.

Appreciate any suggestions on this problem.

share|improve this question
    
What command are you using to mount the drive after a reboot? Are you unmounting the loopback device before rebooting? –  DerfK Jun 11 '12 at 23:41
    
I am not unmounting the loopback device before reboot. I simply do a mount -n -o loop,rw <loopback device> <mount point> –  cvb Jun 12 '12 at 0:09
    
By <loopback device> do you mean /dev/loop1 or /mnt/s/lodev? –  psusi Jun 12 '12 at 15:38
    
Hi: I mean /mnt/s/lodev, I also tried using /dev/loop1 after performing losetup /dev/loop1 /mnt/s/lodev. –  cvb Jun 12 '12 at 16:59
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.