Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

While using ADSI Edit I made a mistake deleting container CN=Servers from under CN=Configuration , CN=Services, CN=Microsoft Exchange, CN=[YourExchangeOrganisationName], CN=Administrative Groups, CN=[LegacyAdministrativeGroupName], CN=Servers

I deleted this folder while following this link

This has caused Exchange services to stop running. Example:

Service MSExchangeMailSubmission. Exchange topology discovery can't find the local Exchange server.

Can someone please help?

share|improve this question
1  
Do you have a backup of a domain controller, or the NTDS database? Did you still have live servers in the legacy administrative group? –  Shane Madden Jun 13 '12 at 5:44
    
Yes we have an image of the entire server from 2 days ago. We can view the container within ADSI Edit on this system. Is there a way to export/import ADSI containers? –  Ash Jun 13 '12 at 7:56
    
Is it possible to restore an ADSI container from active directory? –  Ash Jun 13 '12 at 8:48
1  
We ended up restoring the container from a backup via active directory authoritative restore. Case closed! –  Ash Jun 14 '12 at 0:12
    
Great! Sorry I didn't get back around to putting up an answer for you - but, put your solution up as an answer so that searchers can find it, we can upvote it, and you can mark it as accepted! –  Shane Madden Jun 14 '12 at 0:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.