Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

this is really a followup to this thread, but I can't edit it there since it was moved there from StackOverflow.

I tried to run apache as an application, as John suggested, and it gives me an error "The specified module could not be found" on this line:

LoadModule php5_module "c:/apps/dev/xampp/apache/bin/php5apache2.dll"

though the dll does exist in this location.

(For modifying httpd.conf I'm following the instructions from Beginning PHP5, Apache and MySQL Web Development, Naramore et al., p.9 ff)

edit
I tried DependencyWalker, which found 4 DLLs missing:

libapr.dll  
libaprutil.dll
ieshims.dll
wer.dll

Should these files be part of a WAMP installation (and hence is XAMPP incomplete) or should they be part of my Windows system (XP pro, that is)?

edit (2009-07-13T16:21+01:00)
I downloaded and installed Apache 2.2.11 (instead of as part of xampp), but here libapr.dll and libaprutil.dll seem te be missing as well. Where can I get these files?

share|improve this question

1 Answer 1

My gut says "dependency problem". Grab the dependency walker from http://www.dependencywalker.com/ and point it at that DLL. I'm guessing that you're going to find that some DLL that the php5apache.dll depends on is not available on your system.

  • libapr.dll - Part of the Apache Portable Runtime library.
  • libaprult.dll - Part of the Apache Portable Runtime library.
  • IEShims.dll - Compatibility DLL for Internet Explorer (replaces the functionality provided by the iebrshim.dll, AcRedir.dll, AcLayers.dll, and shimeng.dll files).
  • WER.dll - Windows Error Reporting

The Apache Portable Runtime should've come along w/ an Apache install you did. I'm wondering if you can find the libapr... files on your computer. Having not installed Apache on Windows recently, I can't recall if those files are supposed to end up in the PATH environment variable or not.

Not sure what to say on the missing IEShims and WER. Do you have any strangeness with Internet Explorer on the machine?

share|improve this answer
    
good gut! :-) There seems to be at least a dependency problem. I edited my question with the details. Thanks already –  Anonymous Jul 13 '09 at 13:14

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.