Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

Regarding choosing mysql server for production server. I have Centos5 a 64bit server, for this can I go for Community Server -> "MySQL Server 5.5.23 Linux AMD64 Binary" that is in GA certified under GNU General Public License v2.0.

Also can I clarify does libaio.so packages are needed by mysql-server as a matter of dependency only for mysql versions 5.5 on any linux flavors?

So to help my business that has lots of OLTP applications can I standardize the mysql servers to have binary distributions for community server on a safer stable release "MySQL Server 5.1.63 Linux AMD64 Binary" without libaio or "MySQL Server 5.5.23 Linux AMD64 Binary" with libaio?

Is my approach is correct? Please correct me if I'm wrong. Thanks!!


Thanks guys I moved to 5.5.25 last week. But initially when application starts it does rebuilding of indeces and huge updates from few selects of abt 150 concurrent threads hitting for updates. So the server load hit upto 65% (load avg). And was never reducing. Its in innodb_flush_log_at_trx_commit | 2 | .But still the reads and writes especially was too high.. the server was thinking to give vmstat results and very slow processing the resources in server. But from DB perspective application team didn't have any problem they had their work smoothly as usual. But I felt the heat. Left untouched in any parameters then slowly it went down after 24 hrs to 0.2 %load avg. Now all is good. But I'm worried abt a concept in mysql not sure how many have noticed it. http://bugs.mysql.com/bug.php?id=65837 . I escalated but it turned into a FR. They say its a feature request , but according to me they consider it as "Forget Request". Have a look and put ur comments.. Thanks again!!

share|improve this question

closed as off topic by Bart De Vos, Scott Pack, Mark Henderson Dec 16 '12 at 21:34

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

3 Answers 3

regarding performance - benchmark based on your specific requirements. it all depends on your workload and dataset.

regarding distribution - you might want to check:

  • what your distribution provides [to have least problems with compatibility, upgrades and security patches] - i tend to do this unless i need bleeding edge features or extra % of performance.
  • binary version provided by oracle
  • third party builds for instance percona server
share|improve this answer

RHEL-original 5.0 doesn't require for sure:

5.5 - maybe (as a package), but according to this report - 5.5 should work, but will not require it: http://bugs.mysql.com/bug.php?id=60544

[root@srv ~]# rpm -q --requires mysql|grep -i aio
[root@srv ~]# rpm -q --requires mysql-server|grep -i aio
[root@srv ~]# rpm -q --requires mysql-libs|grep -i aio
[root@srv ~]# rpm -qa |grep aio
[root@srv ~]# rpm -q mysql-server
mysql-server-5.0.95-1.el5_7.1
[root@srv ~]# ldd /usr/libexec/mysqld|grep -i aio

Your approach - you are thinking about shared libraries and packaging, async io, is definitely correct.

The question is what you will trust GA-provided binaries or Centos/RHEL binaries? I use binary packages compiled from Fedora SRPMS. Never had any problems for a 5-6 years in shared hosting environment and enterprise use too.

Thanks for tip - interesting.

share|improve this answer

Don't forget to test Percona builds, they have tons of enhancements and bugfixes, most of which, but not all, are also in an official 5.5 release.

I don't think focusing on 5.1 will bring you much, 5.5. is GA for a long time now, you'll end up having to upgrade again after you consolidated.

share|improve this answer

Not the answer you're looking for? Browse other questions tagged or ask your own question.