Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a created a seperate volume pool for tapes that I use for offsite backup. Once the backup is complete, I remove the tape and re-run the robot inventory.

The inventory sees that tape removed, but the tapes stay in the pool. When I try to 'delete' the tape via the gui , I get error 91.

Anyone know how I remove these tapes from netbackup?

share|improve this question

3 Answers 3

up vote 4 down vote accepted

You don't, at least not while the tape has useful data on it.

Once the data on it has expired, you can remove the tape from the pool by clicking on it in the media manager, selecting "Change", then change the pool (presumably to your scratch pool so it will get selected and used as needed).

share|improve this answer

Kyle, it sounds like your are trying to replicate the "Vault" functionality of NetBackup, which can be setup to detect tapes which have been used and manually eject them on a daily, weekly, or whatever basis.

This used to be an expensive kludge in older versions of NetBackup, but works pretty well in 6.5. It does require a separate license though.

It is possible to script this activity yourself, but it is not the Volume Pool which you are changing (which refers to a logical grouping of tapes, often by purpose or retention) but the Volume Group (which refers to the physical location of tapes. 000_00000_TLD is the rather imaginatively named Volume Group name for "in our first DLT library", and "VAULT-PRIMARIES-HMED1" is our first off site location).

The commands you need are:

vmquery -rn 0 -b # use to check what tapes in your robot (-rn 0) were assigned, i.e. used.

Then for each of those, use:

vmchange -res -multi_eject -ml T00036 -rn 0 -rt TLD -rh hpstmed001 # Eject tape T00036 from DLT robot 0 on host hpstmed001

Read the command reference, because I guarantee that those command syntax's are not correct!

Regards,

Jonathan

share|improve this answer

This is designed behaviour on the part of NetBackup. Why do you want to remove the tapes from the pool?

share|improve this answer
    
Good question :-) I just figured its going to get messy over time. Do they ever get removed automatically? –  Kyle Brandt Jul 13 '09 at 14:19
    
David Mackintosh has got it re: what happens over time. The backup sets expire and then you can change the pool back to your scratch pool. –  Evan Anderson Jul 13 '09 at 14:30
    
Do they then ever leave the scratch pool? –  Kyle Brandt Jul 13 '09 at 14:57
    
Not unless you delete them. I don't believe there's any mechanism to automatically delete scratch media in NetBackup. The assumption, I believe, is that you'd want to keep the media there to track them permanently. –  Evan Anderson Jul 13 '09 at 15:09
    
We use the scratch pool as the place to put unused media. NetBackup is configured to pull media from that pool when required, and the first thing it does is re-assign it to the correct pool for the pending backup. This way you don't have to pre-allocate media in pools for operations, since NetBackup can do it on an as-needed basis. With this model you wouldn't have any "active" data on scratch pool tapes. –  David Mackintosh Jul 13 '09 at 15:38

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.