Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

OS: CentOS release 6.2

In nginx.conf, I set web user as nginx as the following,

user nginx nginx;

The mod of plugin/uploads folders is like the following

drwxr-xr-x. 11 nginx nginx 4096 23:09 plugins
drwxr-xr-x.  4 nginx nginx 4096 11:13 uploads

As you see, the plugins/uploads folders are owned by nginx, and "rwx" by nginx, but why when I try to update plugins via wordpress dashboard, I still get permission denied.

Thanks,

Adam

share|improve this question
    
Where are those directories? And is SELinux set to enforce? –  Shane Madden Jun 14 '12 at 4:59
1  
Is your php part running as php-fpm or somehow else? If it ir running as php-fpm you need to check as what user it is running and chown your wordpress root directory to this user. –  Logic Wreck Jun 20 '12 at 11:56

1 Answer 1

up vote 0 down vote accepted

It's php-fpm settings which override the user/group settings in nginx.conf, and I just need to set to "nginx" and fixed the problem.

http://www.caiapps.com/web-user-and-group-setting-in-nginxphp-fpm-env/

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.