Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've painted myself into a corner. I've just installed Service Pack 1 on a Windows 2008 R2 server that is hosted in a remote datacentre with no possibility of logging in with a 'real' screen and keyboard. SP1 seems to have broken Remote Desktop protocol (RDP), I get to the log-in screen, log in and briefly see the Welcome message, then the RDP session is terminated like so:

RDP session disconnect dialog

The service provider (OVH) has a virtual KVM thingy that is supposed to help out in this situation, but the server blue-screens when booting into that mode (it is some sort of virtual environment apparently). OVH engineers say that vKVM isn't supported for 2008 servers, so that tool is useless... almost. The one ray of hope is that I am able to boot the server into safe mode using vKVM and it doesn't blue-screen, but:

  • I can't uninstall the service pack because the server manager doesn't run in safe mode
  • I can't install VNC because Windows Installer doesn't run in safe mode
  • I can't install updates because Windows Update doesn't run in safe mode (anecdotal evidence suggests that installing further updates would have solved this issue).

There isn't a full system backup of this server because the backup system is based on FTP and it just wasn't feasible, so I can't simply restore from backup. All of the important data is backed up, however. So I have the option to rebuild the server from scratch, I'd really hope to avoid that though as the down time is undesirable.

Any suggestions on how I can paint myself back out of this corner without a full reinstall? e.g. is there some remote access software that can be installed in safe mode? Is there a known fix for RDP? Is there a way to roll back a service pack from safe mode?

share|improve this question
Try Teamviewer, I think it can be installed in safe mode: – Logman Jun 13 '12 at 16:33
is there a single file version of VNC that doesn't require an install? – uSlackr Jun 13 '12 at 16:38
can you roll back to a previous restore point? – uSlackr Jun 13 '12 at 16:39
have not tried this but… – tony roth Jun 13 '12 at 17:05
This happened to me too. It appears that fully patching after the service pack fixed it. – Bigbio2002 Jun 13 '12 at 17:06
up vote 4 down vote accepted

Okay.. had some coffee and thinking a little straighter. Deleting previous responses and providing better info:

The original release of the update from KB2667402 causes this issue. It notes in the known issues that applying SP1 after the update causes RDP issues.

The patch was re-released to address and correct the RDP issue.

So, you should be able to start the server up normally and remotely uninstall the original version of the patch via WMI

wmic /node:<SERVER> /user:<USER> process call create "powershell wusa /uninstall /kb:2667402 /quiet /forcerestart"

After uninstalling the KB and the subsequent forced restart, you should be able to RDP to the server again. At that point, you should be able to install the updated version of the same KB

Footnote: This did solve the problem but it wasn't necessary for me to use WMI remotely. I was able to boot into safe mode using the virtual KVM and use the WUSA command line directly to uninstall KB2667402. All was then working after a reboot. This allowed me to sidestep all the firewall and permissions issues associated with letting a remote user access WMI.

share|improve this answer
heck why not run the kb* via wmic – tony roth Jun 13 '12 at 17:11
or for that matter just restart rdp so see if that fixes things. – tony roth Jun 13 '12 at 17:12
Would make sense to run the KB via WMI - not thinking straight today. Don't think restarting RDP will work though. I just realized my command is wrong too as I have it uninstalling the KB that I just told him to install. LOL - gotta go correct it – Rex Jun 13 '12 at 17:13
also doesn't wusa use the msi process? – tony roth Jun 13 '12 at 17:16
hahah damn now I'm not thinking correctly!!! – tony roth Jun 13 '12 at 17:17

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.