Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

On one of my Domain Controlers, I have a folder that was created by a service. When I try to access it using Administrator credentials I get access denied. Administrator has ownership of the parent directory and full right everywhere else. Attempt to apply to child generates an Access Denied.

This is a temp folder and needs to be emptied at regulr interval. I use to be able to do it but last time I cleared it, I forgot to re-create it and the service did.

How can I reclaim that folder ?

share|improve this question

You state that the admin has ownership of the parent directory - have you tried to explicitly take ownership of the folder in question?

share|improve this answer
Can't access that folder at all. Clicking/Right Clicking on it grants an instant Access Denied. – Laurin Jun 13 '12 at 20:18
Then you're not logged in as an administrator. An administrator can take ownership of and file/folder on the machine. – MDMarra Jun 14 '12 at 2:13
Oh but I am. Logged in as Domain Administrator, this is a DC. Also tried with my own account (member of Administrators) - no luck there either. – Laurin Jun 14 '12 at 12:33
Is the directory encrypted at all? – Rex Jun 20 '12 at 21:33
No encryption at all. – Laurin Jun 26 '12 at 18:28

Take owership of the subfolder. If the service breaks inheritance and sets a new owner, then you'll need to explicitly take ownership of the troublesome folder and check the box that applies it to all contained objects. Then, change the permissions like you would for anything else.

share|improve this answer
Can't take ownership - I tried! – Laurin Jun 13 '12 at 20:21

Take ownership of the parent folder (that you can access), and tick the box to replace the owner on subcontianers and objects.

(Properties -> Security -> Advanced -> Owner -> Edit)

One that's done, you'll be able to change the permissions to allow Administrators Full Control.

share|improve this answer
Tried that, took ownership of parent (which as Administrator I already had). When I apply to children I get an Access Denied for that subfolder. – Laurin Jun 14 '12 at 12:32

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.