Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

How to make Cadaver connect to a WebDAV server that uses Kerberos authentication?

Usually cadaver http://localhost:8080/alfresco/webdav works, I can browse files, but on a network with Kerberos I get:

Could not open collection:
401 Unauthorized

Even though I have logged in with kinit successfully and have a valid ticket.

I can see that Kerberos support has been implemented in Cadaver in 2005. Is there a special syntax to use? No info in the man.

share|improve this question

1 Answer 1

Just stumbled upon this. This is not Cadaver's fault. It is using libneon as transport. First, you must compile neon with GSS-API support + you have to apply a patch to support SPNEGO, it's passing naked Kerberos tickets only.

Here's the discussion: http://lists.manyfish.co.uk/pipermail/neon/2012-June/001475.html

Here's the verified patch: http://lists.manyfish.co.uk/pipermail/neon/2012-July/001494.html

share|improve this answer
    
Interesting! Do you have any link to the procedure or the patch? –  Nicolas Raoul Feb 5 '13 at 11:16
    
@NicolasRaoul, see edit. –  Michael-O Feb 5 '13 at 13:08
    
Thanks a lot! I will try this as soon as possible. –  Nicolas Raoul Feb 6 '13 at 7:27
    
Please report back, I am inclined to try that too. –  Michael-O Feb 6 '13 at 8:53
    
I was able to compile cadaver with neon 0.29.7-dev but when I run cadaver, it fails with a segfault. From the core dump I do see this: OPTIONS /files/ HTTP/1.1 User-Agent: cadaver/0.23.3 neon/0.29.7-dev Keep-Alive: Connection: TE, Keep-Alive TE: trailers Host: ...:18080 Authorization: Negotiate YIIQLwYGKwYBBQ... So, someone has to fix cadaver with neon first. I know that neon works because I have verifed it in tandem with Subversion. –  Michael-O Feb 6 '13 at 10:18

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.