Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

To setup munin I did the following:

yum install munin munin-node -y

Then set the

htmldir /var/www/virtualhosts/ssl.foo.com/bar

[foo.com]
    address 127.0.0.1
    use_node_name yes

In /etc/munin/munin.conf. I kept the user for munin root. Restarted munin (/etc/init.d/munin-node restart).

Munin is runing:

[root@server ~]# ps aux | grep munin
root     41077  0.1  0.0 143236  8508 ?        Ss   10:48   0:00 /usr/sbin/munin-node
root     41432  0.0  0.0 103268   828 pts/0    S+   10:48   0:00 grep munin

[root@server ~]# netstat -anp | grep munin-node
tcp        0      0 0.0.0.0:4949                0.0.0.0:*                   LISTEN      41077/munin-node  

However, there is nothing populated in the htmldir. What could have gone wrong?

Note:

  • SElinux is disabled
  • /var/log/munin/munin-node.log does not mention any errors
  • munin comes from epel repo

All munin related packages:

[root@server ~]# yum list installed | grep munin
munin.noarch                        1.4.7-5.el6                        @epel    
munin-common.noarch                 1.4.7-5.el6                        @epel    
munin-node.noarch                   1.4.7-5.el6                        @epel
share|improve this question
add comment

2 Answers 2

/etc/init.d/munin-node restart and run munin-update cmd as munin user account where your server is configured this will let u know that munin server is communicating with munin-node..

and try this #telnet foo.example.com 4949 and If the plugin does run with munin-run but not through telnet, you probably have a PATH problem and also Check that the plugin's field name have the .value directive on each field name

share|improve this answer
add comment

I'm not sure if you changed it or not, but does the [foo.com] hostname match both in your munin.conf file and your munin-node.conf file? that stopped munin from working for me if I recall correctly.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.