Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have a machine on the LAN with an rsync daemon (on Debian Squeeze) running on default port 873 with this config:

[sync]
    path = /mnt/hux/WORK
    read only = false
    uid = dco

I'm connecting with it as follows:

rsync -az --delete --force --progress /path/to/stuff/ hostname::sync/stuff

That works fine.

Now I have another server, outside the firewall, which blocks port 873. So, I have rsync listening on port 443 instead, but everything else is configured the same. However, when I try connecting to it like this:

rsync -avvz --delete --force --progress /path/to/stuff/ hostname:443::sync/stuff

I see:

opening connection using: ssh hostname rsync --server -vvvlogDtprze.iLsf --delete --force . 443::sync/stuff

And it asks me for a password. Is there some way I can change the port and not have rsync assume I want to use SSH? I'd like to just use rsync as I'm doing on the LAN.

share|improve this question

2 Answers 2

up vote 0 down vote accepted

use

rsync -avvz .... /path/to/stuff/ rsync://hostname:443/sync/stuff

The doublecolon does not support a port notation.

share|improve this answer
    
Ah - bingo! Thanks. I'd actually tried that, but not with the rsync:// notation. –  Gilgongo Jun 15 '12 at 12:32
    
You're welcome! Ran into this myself, made me strange headaches. Mixed both notations and did not see they differ in this aspect... –  Michuelnik Jun 18 '12 at 10:29

Try using the --port=443 option:

rsync -avvz --delete --port=443 --force --progress /path/to/stuff/ hostname::sync/stuff
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.