Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I followed the instruction here to set up and deploy a VM Role onto Azure. It all worked fine.

But I cannot RDP onto it.

If you check the link above, after I click 'Connect' in step 4, it remains busy and never goes into step 5.

This error (check screenshot below) arises every single time. Any tips/help/ideas? Error screenshot

share|improve this question

migrated from stackoverflow.com Jun 14 '12 at 17:52

This question came from our site for professional and enthusiast programmers.

    
Do you have another network you can try it on? A firewall could be blocking your RDP port (3389). –  SliverNinja Jun 1 '12 at 14:43

3 Answers 3

up vote 2 down vote accepted

Based on above screenshot your virtual machine whatever.cloudapp.net is not accessible. It is possible that:

  1. Virtual machine is not running and because of that the machine is not available
  2. Virtual machine is running but met some problem and because of Remote Connection services is not running and you can not connect
  3. You are trying to connect to Virtual machine incorrectly because your screenshot tells that you have either created a RDP file to connect or trying to connect directly by creating a new connection.

If you are sure that your Azure Virtual machine is running properly, then I believe #3 is your main problem. This is because the RDP access script which you download from your own portal has some cookie info which is needed to connect to your Virtual machine.

The best would be to download the RDP access script directly from your Portal related to your Virtual Machine instance and then try to connect it.

If you need help, please follow my this blog which will guide you step by step on this regard.

share|improve this answer
    
Sorry for the delay, it was #2 of your suspicions and I had not enabled RDP on the VM. –  dushyantp Jun 19 '12 at 9:00

You can't connect to your instance directly. The load balancer needs some extra information to make the connection possible (to which instance you need to connect). Try going through the portal and pressing the Connect button on one of your instances:

enter image description here

If you open the file with notepad, you'll see the extra information that will be sent to the load balancer.

share|improve this answer
    
Hi, yes I have done that, after that only the RDP gives the error (in the screenshot) –  dushyantp Jun 1 '12 at 16:30

Have you provided the port number as well in the RDP connection?

In my case it was port 59104. Thus in the computer field, you need to enter:

whatevermachinename.cloudapp.net:59104
share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.