Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have a shiny new QNAP NAS (TS-879U-RP), and I'm trying to mount it to our big ol' RHEL server in the same manner as our other two QNAP NAS devices. The IT department won't give me the root privileges to the NAS, so I can't SSH in (I know, I know). The first thing I did was to, via the QNAP web admin interface, create a network share named "Runs." I then added the IP of the RHEL server to the permissions list:

NAS Web Admin Screenshot

On the RHEL server, I then added the following line to /etc/fstab:

[IP of NAS]:/Runs      /mnt/gsrnas3    nfs     defaults        0       0

Aside from the IP and the specific mount directory name, this is how I mounted the other two NAS devices.

I then created the gsrnas3 directory under /mnt/, and then ran `mount /mnt/gsrnas3'

I got the following error:

mount.nfs: Connection timed out

My first thought is that it's a ports issue, but I don't have enough specific experience with this issue to know for sure. I have two other NAS devices by the same manufacturer already mounted to this RHEL server, so that leads me to believe the configuration issue is on the NAS side of things. I can ping the NAS device successfully from the RHEL server. Not being able to SSH into said NAS is a huge hassle, though. Any ideas?

share|improve this question
    
@Dave Forgac Thanks Dave! –  DeeDee Jun 19 '12 at 2:35

1 Answer 1

up vote 1 down vote accepted

OK, this is embarrassing, but to my credit it wasn't in TFM:

Aside from setting particular NFS settings for the share, you have to explicitly enable NFS from the web admin page:

doh

So...I'm now rosy-cheeked yet relieved.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.