Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

We have configured a SMTP server on IIS. We have not configured any SPF rule. Some emails are going straight to the badmail folder. Most of them have this error message:

Address does not pass the Sender Policy Framework

Is there any way to disable that? I know this is insecure and spammers could use it to send spam, but I really need it to be disabled for now until I have configured and tested the SPF correctly.

share|improve this question
    
Have you used a SPF validator such as kitterman.com/spf/validate.html to confirm there is no SPF record? Does the MX record for your domain point to an A record that is mapped directly to this SMTP server? –  Andy Shinn Jun 15 '12 at 17:56

1 Answer 1

You can disable anti-spam filtering on the receive connector. console -> Org config -> Hub role -> Anti spam filter tab

The behaviour you are seeing is your receive connector checking that the people who send you a message have a valid spf record. There really shouldn't be anything to test. If a company is sending you email from a domain with an invalid spf record, then they will have problems with pretty much everyone, not just you.

That you have an spf record or not is of no consequence for messages that you receive.

share|improve this answer
    
What do you mean by "console" ? –  Rafael Colucci Jun 18 '12 at 18:43
    
Exchange Management Console - often shortened to EMC (technet.microsoft.com/en-us/library/bb123762.aspx) –  Ian Murphy Jun 22 '12 at 14:07
    
@Ian I don't think he's talking about Exchange, he's talking about a standalone SMTP server –  Mathias R. Jessen Jul 26 '12 at 18:00

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.