Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

In trying to install Apache 2.0 Agent 2.202 for RHEL5 Linux 64bit, the dialogue appears as follows.

# export JAVAHOME=/usr/java/jdk1.6.0_24/; echo $JAVAHOME 
/usr/java/jdk1.6.0_24/

# ./setup 
Launching installer...
Attach to native process failed

On the server we have the following JREs and I've tried both.

# java -version
java version "1.6.0_22"
OpenJDK Runtime Environment (IcedTea6 1.10.8) (rhel-1.27.1.10.8.el5_8-x86_64)
OpenJDK 64-Bit Server VM (build 20.0-b11, mixed mode)

$ sudo rpm -qa | egrep "(openjdk|icedtea)"
java-1.6.0-openjdk-1.6.0.0-1.27.1.10.8.el5_8    

And SElinux appears to be off:

# cat /etc/sysconfig/selinux
SELINUX=disabled
SELINUXTYPE=targeted

Update after solution was found:

I have some minor progress to report. I removed all traces of Java from our test server. As you can see below, I downloaded a mixed mode copy of Java as recommended by a few friends and colleagues. I downloaded jdk-1.6.0_31-fcs.i586.rpm from (ftp.)ScientificLinux.Org and installed it.

# rpm -qa | grep jdk
jdk-1.6.0_31-fcs

# java -version
java version "1.6.0_31"
Java(TM) SE Runtime Environment (build 1.6.0_31-b04)
Java HotSpot(TM) Server VM (build 20.6-b01, mixed mode)

# echo $JAVAHOME
/usr/java/jdk1.6.0_31

And, instead of saying "Failed to attach to native process," I'm now prompted with the following.

# ./setup
Launching installer...
You are running the Installation/Uninstallation program for the Sun Java(tm)
System Access Manager Policy Agent.

The Installation program consists of one or more selections that provide you
with information and let you enter preferences that determine how the Sun Java
(tm) System Access Manager Policy Agent is installed and configured.
share|improve this question
    
Did you try setting JAVAHOME? –  mgorven Jun 16 '12 at 5:38
add comment

1 Answer

up vote 0 down vote accepted

Various on-line investigations seem to point to a 32-bit vs. 64-bit issue (as well as possibly some of the packages I previously suggested you were missing). So, whilst it may be overkill, I'd say:

yum install java-1.6.0-openjdk-devel
yum install java-1.6.0-openjdk-plugin
yum install icedtea-web

If that doesn't cure things start looking for ia32-libs and libstdc++5 or libstdc++6. The specifics on how to install those are "left as an exercise to the reader" i.e. I haven't a clue but it will probably involve either (1) adding a new repository to your list or (2) adding RPM's by downloading and installing with rpm directly. For option number two, see the RPM search system at http://rpm.pbone.net/

share|improve this answer
    
It looks like I have epel and rhel-x86_64-server-5. Searches for "ia32" on rpm.pbone.net didn't return anything useful at the moment. –  Richard Jun 25 '12 at 18:37
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.