Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am getting a 500.19 error when going to my site. I've tried to change the permissions on the directory but for some reason since about 2hrs ago the IIS_IUSRS group is completely gone now. I think I messed it up, how can I fix this?

Update: I found the group, it just wasn't added to the inetpub folder, but now when I go to the website: www.example.com it forces you to login. I'm new to this web admin think I would GREATLY appreciate any help.

share|improve this question

3 Answers 3

Ok, think I got it, before I only had wwwroot permissions to IIS_IUSR, but when I add IUSR it works.

share|improve this answer

Raymond, You may just need to re-add the permissions. Perhaps something else you were doing on the server reset the permissions. -Chris

share|improve this answer
    
Ok, i found i still have the group, but now when I go to the site it makes you login, how do i make it viewable to all again? –  Raymond Jun 15 '12 at 21:24
    
Have you given read access to the folder? Additionally, check anonymous access in IIS. –  Chris Anton Jun 16 '12 at 0:29

Is it possible that somehow Anonymous authentication is disabled? On your website goto authentification select Anonymous authentication and click enable. (and perhaps also check your folder permissions that Iusr still has at least read rights)

share|improve this answer
    
Its enabled for the Home server and the default site, (there is also a windows authentication on the default site, ive tried that enabled and disabled but no luck) I am going to see if I can copy the IIS_IUSER group policy by downloading the Group Policy Management Console from another computer running Server 2008 (non R2) then import it to the current one to see if that may help. –  Raymond Jun 15 '12 at 22:03
    
Is the default site the one you are getting the login box from? Because if you enable windows auth on a website and login anonymous then its normal to get a login dialog I think. Is windows auth needed for that website? (are you using auth over Intranet?) Otherwise you should disable it if you want anonymous access to your site. –  Joost Verdaasdonk Jun 15 '12 at 22:08
    
Another tip is to enable failed request tracing to figure out the reason for the 500 error: link –  Joost Verdaasdonk Jun 15 '12 at 22:15
    
I was trying to setup webdav, but I dont need it anymore, I disabled windows auth but now I just get a 401 error –  Raymond Jun 18 '12 at 18:08
    
Hi Raymond. if you don't have windows auth and you do have anonymous auth then it must be the permissions for the anonymous user on the site directory. Like I said in the above comment perhaps you should try to trace your site for 401 errors to get info about which user is denied. Good luck –  Joost Verdaasdonk Jun 18 '12 at 18:22

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.