Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Google Chrome shows: "Error 107 (net::ERR_SSL_PROTOCOL_ERROR)" everytime I reboot my server. However, if I restart apache(# service apache2 restart), everything works great.

Nothing appears on Apache error log(/var/log/apache2/error.log), and I'm using debian 6.

share|improve this question

1 Answer 1

up vote 1 down vote accepted

Resolved!!

The setting in ports.conf was:

 <IfModule mod_ssl.c>
     Listen 443
    NameVirtualHost 1.2.3.4:443 # ipv4
    NameVirtualHost 1:2::3:4:5:6:443 # ipv6
 </IfModule>

sites-available/default-ssl was:

<VirtualHost 1.2.3.4:443>
...
...
</VirtualHost>

<VirtualHost 1:2::3:4:5:6:443>
...# same setting as ipv4
...
</VirtualHost>

When I fix this to the following, https works after rebooting!

ports.conf:

 <IfModule mod_ssl.c>
     Listen 443
    NameVirtualHost *:443
 </IfModule>

sites-available/default-ssl:

<VirtualHost *:443>
...
...
</VirtualHost>

Thanks to these two pages although it's not the same problem:

http://ubuntuforums.org/showthread.php?t=806884 http://www.noah.org/wiki/Apache2_Invalid_method_in_request_%5Cx16%5Cx03%5Cx01

share|improve this answer
    
That's a strange config to have - it's definitely non-default, since you have your own IP address in there! Do you have any software installed that managed or modifies your Apache configuration? –  Shane Madden Jun 17 '12 at 5:16
    
It was set by myself from some tutorials on Google... –  benck Jun 17 '12 at 11:21

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.