Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

At work we use domains like abc-01, which work fine on windows. Whilst developing mobile applications we already saw that this doesn't work on both iOS and android which we fixed for a few specific domains (by setting the dns up that abc-01.def.local also works in those) and was assumed to be caused by it being an invalid domain. Now however it's necessary to connect through VPN from a mac and changing all relevant domains is not an option at the moment (far too many of them and would require changing the settings of far too many applications), so I was hoping whether somebody knows a trick or setting to get this to work on mac (or even linux in general).

share|improve this question
    
Please elaborate on your meaning of "domains". Are you referring to your AD domain or are you referring to DNS zones unrelated to AD that you host internally? –  joeqwerty Jun 16 '12 at 12:50
    
Truth be told, I have no idea at all what AD does and what AD domains are, so I guess the second (that's why I labeled it DNS as well). Either way, I found the solution which I posted as an answer below. Apparantly it has to do with automatically adding the search domains. –  David Mulder Jun 16 '12 at 15:30

1 Answer 1

After a lot more searching I found out the solution. The clue was that on newer windows versions we already were instructed at work to enable "Allow DNS suffix appending to unqualified multi-label name queries" and "Primary DNS suffix devolution", but as it was awhile since I had installed a desktop PC at work I forgot about this + didn't see the link.

Either way, next for mac it's necessary to start mDNSResponder with AlwaysAppendSearchDomains to get it to work (which made me realize that abc-03 for example wasn't the real domain name in the first place). To achieve this it's necessary to open /System/Library/LaunchDaemons/ com.apple.mDNSResponder.plist and edit the ProgramArguments array adding <string>-AlwaysAppendSearchDomains</string> and next reloading the plist.

Took awhile to find the solution, but happy that I got it to work. Although I am a programmer I really have quite limited knowledge about networks and anything in this area, so I still have no clue what those windows settings do exactly, but at least the mac flag I can comprehend. Here is the source btw where I found the solution.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.