Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

All of a sudden my XAMPP installation is playing silly buggers when I try to Cake bake.

I get a recurring error:

SQLSTATE[HY000]: General error: 6 Error on delete of 'C:\xampp\tmp\#sql...MYD' (Errcode: 13)

Where the file name changes between attempts. I have tried reinstalling Xampp to no avail. I have also tried baking projects that were completed and are known to work but stil get the error (so I do not think it is my database schema).

The error also popped up in phpmyadmin once but I cannot replicate it. It only happens all the time when I try baking with CakePHP 2.1.3-18

share|improve this question
    
Looks like file permission error. It's possible it only happens when temporary table is used. –  c2h5oh Jun 16 '12 at 12:23
    
That makes sense... but it is running on Windows. Any idea how to correct the permissions? –  Andy Jun 16 '12 at 12:36
    
Contrary to popular belief Windows does have some access control ;-) and it could be causing this. Check what user is running mysqld process and if that user has permissions to access \xampp\tmp if you find the problem there either change mysql tmpdir to somewhere it can access or change \xampp\tmp permissions –  c2h5oh Jun 16 '12 at 12:41
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.