Server Fault is a question and answer site for system and network administrators. Join them; it only takes a minute:

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I have been having a strange problem with our locally hosted DNS (bind on ubuntu server). We have a DNS server that hosts several locally defined domains (for example, myserver.localnetwork). Normally if I point a browser to myserver.localnetwork, it works without problem. However, about once every 30 minutes or so it will return a "Problem Loading Page". Firefox will state "could not find the server at myserver.localnetwork". If I wait about 5 minutes, it will start working again. This seems to happen across multiple OSs and on all the network computers. It seems to happen at some sort of regular interval which has made me suspect some DNS server problem (or possibly DHCP), but I really have no idea what would cause this sort of problem.

Any ideas?


  1. Although the problem happens on multiple computer, it does not happen at the same time. While one computer can't find the server, other computers will be able to find it just fine
  2. Even while Win 7 Can't find the server, nslookup myserver.localnetwork returns the correct ip and correct DNS server
  3. On Ubuntu, if I hold down F5 to refresh the page, it will usally fix the problem. However, this doesn't work on windows 7.
share|improve this question
Enable debugging in bind and look for relevant log messages near the time when the issue occurs – Hyppy Jun 18 '12 at 13:49
When this happens, do other host names resolve properly? When this happens, what is the output of dig myserver.localnetwork? – Michael Kjörling Jun 18 '12 at 13:54
@Micheal when it happens, anything .localnetwork will not work, but anything external will (even though both go through the local DNS server). – Daniel Jun 18 '12 at 16:42

Check if there is any DNS or IP conflict. You could also see if the TTL for the applicable zone file matches the frequency of the error. Windows caches DNS records ipconfig /flushdns at command line to clear it out, Linux doesn't. So you just have browser cache to deal with. This would explain the discrepancy and variation between systems as their individual TTLs would clear out at individual times.

Aside from that you could check if anybody on the network is spoofing MAC addresses and rerouting traffic.

share|improve this answer
up vote 0 down vote accepted

I have tried something which I think has worked. Previously I was handing out two DNS Servers via DHCP. The first was a local server and the second was a remote one used as a backup. Since I was running out of ideas, I tried switching it to only give out the local DNS Server which as seemed to fix the problem.

share|improve this answer
Which means your primary was not responding in a timely enough manner. Maybe look into performance issues there. Measure the time to receive a response using the time stamps in packet captures. – SpacemanSpiff Oct 15 '12 at 13:26

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.