Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have an IBM 9406-250 with V5R1 and IPv4 only connectivity, and want it to be reachable over IPv6. I cannnot install an IPv6 stack on it, but I want it to be accessible by IPv6 so I can drop the requirement to VPN to my home network.

I have an OpenWRT device running, which takes care of the IPv6 routing on my network and the tunnel to SIXXS, and I was wondering if it is possible to assign another IPv6 address to that device, and route it to the IPv4 IBM computer.

Which software do I need for this, and how is this technique called?

Edit:

One port would be sufficient actually, would it be possible to add an extra IP to the interface of the OpenWRT box, and redirect port 23 from the AS/400 to port 23 on the IPv6 IP?

share|improve this question
    
No idea if it supports it, but have a look at NAT64. –  mgorven Jun 18 '12 at 17:00
    
I'm looking for the reverse of this: connect IPv6 clients to an IPv4 host, if I understand correctly this allows me to connect to IPv4 hosts from an IPv6 only network? –  friedkiwi Jun 18 '12 at 18:18
    
I know that it's the opposite of what you want, which is why I don't know if it'll work. You may be able to configure it in a way to achieve what you want. –  mgorven Jun 18 '12 at 18:58
    
I editted the question to make myself more clear, I don't want to put the entire IPv4 subnet IPv6 reachable this way, one port would be enough actually. I currently have an SSH tunnel setup which connects to localhost, and redirects the port 23 to IPv6... –  friedkiwi Jun 18 '12 at 19:26

2 Answers 2

You could use socat to relay packets, for example:

socat TCP6-LISTEN:23,fork TCP4:192.168.0.10:23
share|improve this answer

IPv6 support is available as of V5R2. If you can update, that might be an easy solution.

Another option is to place the beast behind a NAT64/DNS64 gateway. You may need a different device, as the last time I looked, NAT64 was not well supported on OpenWrt.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.