Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I run Windows XP.

When I try to "Enable Hibernation" from Control Panel --> Power Options, I get the following error.

Power policy manager unable to reserve hibernate file. The file or directory is corrupt and unreadable

I see lots of solutions posted , but most of them involve deleting some system file, or accessing the registry.
Is there any way I can avoid such things and enable hibernation?

share|improve this question

closed as off topic by Sven, EEAA, sysadmin1138 Dec 17 '12 at 13:27

Questions on Server Fault are expected to relate to professional server, networking, or related infrastructure administration within the scope defined by the community. Consider editing the question or leaving comments for improvement if you believe the question can be reworded to fit within the scope. Read more about reopening questions here.If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

Probably not, no.

hiberfil.sys is the file used to save the contents of your RAM and "hibernate" the system. It's also marked as a system file, because, well, it is one. If it's corrupted and needs to be deleted or have its permissions editted, then you're going to have to delete or edit a "system" file.

Incidentally, I'm of the opinon that on a site for IT professionals, we probably shouldn't see such a strong desire to avoid changing files with an arbitrary "system" flag... maybe SuperUser is more your speed?

share|improve this answer
    
OK! sorry about that. guess I sounded too noobish :( Anyway I can't delete the hiberfil file now. Says the file is corrupt and unreadable Any pointers on that? –  SatheeshJM Jun 19 '12 at 13:35
    
Check permissions, try the command line, try safe mode... worst case, boot into another OS with a liveCD or what have you, and delete it through that. –  HopelessN00b Jun 19 '12 at 14:26
    
Ok. I did the simple thing. Ran a Check Disk on my C: drive. Worked like a charm. (actually my autochk.exe was also corrupted.Since check disk can only be done on C: during booting as windows is installed there, I had to retrieve it from the CD. Everything works well now ) Thanks a lot anyway! –  SatheeshJM Jun 19 '12 at 22:23

Not the answer you're looking for? Browse other questions tagged or ask your own question.