Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I just updated my Debian and Courier imap is not logging in anymore. Pop3 service works fine. In the logs I can see that authdaemon authenticates, but imapd gets stuck and does not return OK.

Logs:

Jun 19 14:06:39 sylar authdaemond: received auth request, service=imap, authtype=login
Jun 19 14:06:39 sylar authdaemond: authldap: trying this module
Jun 19 14:06:39 sylar authdaemond: using search filter: (&(objectClass=CourierMailAccount)(uid=vsilva))
Jun 19 14:06:39 sylar slapd[6421]: conn=1111 op=18 SRCH base="ou=users,dc=xxx,dc=com,dc=br" scope=2 deref=0 filter="(&(objectClass=CourierMailAccount)(uid=vsilva))"
Jun 19 14:06:39 sylar slapd[6421]: conn=1111 op=18 SRCH attr=homePostalAddress mailbox cn userPassword uid
Jun 19 14:06:39 sylar slapd[6421]: conn=1111 op=18 SEARCH RESULT tag=101 err=0 nentries=1 text=
Jun 19 14:06:39 sylar authdaemond: one entry returned, DN: cn=Vagner Silva,ou=users,dc=xxx,dc=com,dc=br
Jun 19 14:06:39 sylar authdaemond: authldaplib: sysusername=<null>, sysuserid=110, sysgroupid=115, homedir=/var/mail/imap/, address=vsilva, fullname=Vagner Silva, maildir=vsilva/, quota=<null>, options=<null>
Jun 19 14:06:39 sylar authdaemond: password matches successfully
Jun 19 14:06:39 sylar authdaemond: Authenticated: sysusername=<null>, sysuserid=110, sysgroupid=115, homedir=/var/mail/imap/, address=vsilva, fullname=Vagner Silva, maildir=vsilva/, quota=<null>, options=<null>
share|improve this question
add comment

1 Answer

I don't know if this is what happened in this case, but one thing that could cause this is a misconfigured firewall that doesn't allow traffic on the loop-back interface. At least I've seen this happen on one of my servers.

share|improve this answer
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.