Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

I have a new installation of WHM and cPanel and I'm adding domains into WHM, but when I try access via cpanel or whm subdomains, I got redirected to cgi-sys/defaultwebpage.cgi.

I've already tried into 3 different computers to check if is cache but the issue persists. I've checked the proxy domains but is enabled by default. What could be wrong?

share|improve this question

closed as off-topic by HopelessN00b Jan 14 at 0:51

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

    
Are the accounts linked to the correct IPs? Do the accounts show up in the apache configurations correctly? –  arjarj Jun 20 '12 at 6:33
    
@arjarj It was all right, seems to be a cPanel misconfiguration. Executing the commands below worked properly. Thanks. –  Danniel Magno Jun 20 '12 at 11:50
    
This question appears to be off-topic because it is about working with a service provider's management interface, such as cPanel. –  HopelessN00b Jan 14 at 0:51

1 Answer 1

up vote 0 down vote accepted

I've contacted the cPanel Support and they told me to execute the following commands:

# /scripts/rebuildhttpdconf
# /scripts/restartsrv_httpd

After that, the subdomains worked properly.

Thanks everybody.

share|improve this answer
    
I get a permission denied. Did you have root access? –  Magpie Dec 16 '13 at 21:19
    
@Magpie Yes. All things related to server administration must be done by root. –  Danniel Magno Dec 17 '13 at 2:07

Not the answer you're looking for? Browse other questions tagged or ask your own question.