Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

From what I understand ballooning should occur only when the host begins to run out of physical memory, somewhere above 90% usage. I have an SQL server running in a three node cluster (64 GB RAM in each host) and it has been assigned 8 GB of RAM as a guest. Over the past few months we have been experiencing intermittent performance issues with various systems and one area that we have highlighted is the SQL server seems to be regularly be ballooning memory. This is despite the fact that the host memory stays consistently below 75%.

Have I misunderstood the triggeres for ballooning and is a 2GB balloon on a fairly regular basis not that much of an issue?

I have (hopefully) attached a picture of the last days worth of memory monitoring on it.

We are running ESX4.1 and the guest VM is Windows Server 2008 R2 running SQL Server 2008 R2

EDIT: Well in light of the suggestion below in the comments from Chopper3 we are making somechanges tonight. A quick test on a low impact server seems to have had the right affect so fingers crossed we should be running at full capacity tomorrow. Could explain lots of possible performance related issues we have been seeing of late.

share|improve this question
1  
Look at the VM's settings, then choose Resources, click on Memory and be sure that the 'Unlimited' box is ticked - I've seen cases where this just gets unticked for some mystery reason and causes this kind of problem. Worth checking anyway. –  Chopper3 Jun 20 '12 at 10:38
    
golly. no idea why it is not set but oddly the test and dev version of the same server have it set and show absolutely zero ballooning. you have given me a starting place to look from now, thanks alot! –  Tim Alexander Jun 20 '12 at 11:10
    
I've seen the very same thing in one of our environments (4.1U1), that bit just got flipped, it's moving to 5.something soon so I'm not too fussed but just wanted you to know. –  Chopper3 Jun 20 '12 at 11:14
add comment

1 Answer 1

up vote 9 down vote accepted

Just for a sense of completeness I'll drop this in as an answer for future reference/searches.

Basically look at the VM's settings, then choose Resources, click on Memory and be sure that the 'Unlimited' box is ticked - leaving this unticked can cause needless ballooning.

share|improve this answer
    
well this morning I am presented with lots of graphs with zero ballooning on them :) Am pretty certain the performance will pick up from this but either way you have answered my question. thanks for the help! –  Tim Alexander Jun 21 '12 at 8:39
    
Bingo - glad to help. –  Chopper3 Jun 21 '12 at 8:40
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.