Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have 2 windows 7 virtual machines on an ESXi host I set up, and I want to get them so that they are accessible on my LAN that I have set up. I read the documentation and it said the virtual network adapters are automatically connected to the physical ones on my host. So I tried to ping both my virtual machines from a physical computer I have on my network, but it says "Request Timed Out." I can, however, ping that physical computer from within my virtual machines. So I was just curious, how can I get them to communicate both ways???

share|improve this question
1  
This site is for professionals, you need to be trained in this stuff, it's not the sort of thing you can just 'have a go' at when dealing with a production system. Not being nasty, just saying you don't want to be messing around with live kit. –  Chopper3 Jun 20 '12 at 17:44
    
I apologize. I didn't want to do this. I was just supposed to be working on software, but I'm the intern. No one here is trained in this stuff and they just gave me a couple books and foisted it on me. I'm sorry, but I have no choice but to 'have a go' at it. Thank you so much for your advice though. I appreciate it ^.^ –  Hannah Jun 20 '12 at 19:00

3 Answers 3

up vote 4 down vote accepted

Take ESXi out of the equation and follow standard troubleshooting steps. Since ESXi uses bridged networking, it presents the guests to the network as if they were physical nodes connected to another switch on yout network.

I'd guess that ICMP Echo isn't allowed through the guest firewalls, or that there is a hardware firewall between the guests and the physical clients that is blocking ICMP.

share|improve this answer
    
Thank you! That was it ^^"" Sorry I don't really know what I'm doing >.< –  Hannah Jun 20 '12 at 19:47
    
@Hannah If this answered your question, you should click the check mark next to this answer to mark it as "accepted". This will let future visitors know what the resolution is, as well as keeping this question from popping up on the front page from time to time. –  MDMarra Jun 20 '12 at 20:07

If it works one way, then they are connected - full stop. Perhaps you have the firewall turned on, in the guests?

share|improve this answer

Is the firewall enabled on the guest system? Are the guests on the same subnet as the host? Do you have the network adapter set as Bridged or NAT?

share|improve this answer
    
There is no option for bridged or NAT in ESXi. All connections are bridged unless you have an isolated vSwitch and are using vShield zones. That's a bit complicated and it's safe to assume that the OP is not using vShield. –  MDMarra Jun 20 '12 at 17:17

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.