Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I did a cPanel move of a Joomla 1.5 website and a PHPBB3 forum from one server to another, and when the DNS changes kicked in all I see is a blank page. The administrator panel works without any problems whatsoever. cPanel works. Website and forum (which is separate from the website) are both blank.

I have then manually downloaded and then uploaded all files (didn't move the databases manually), and some files wouldn't upload because of 555 file permissions. I changed the permissions to 777 temporarily to overwrite the file with the manually uploaded one. So all files are now the same as they were on the old server.

Even when I turn the Site Debugging on, the screen is blank.

There is no hidden index.html or default.html file which could be causing the problem.

The entire account was moved with cPanel so it's the same on the old server and the new server. The hosting provider reports no problems. The DNS changes kicked in two days ago.

PHP is working, as this link works: http://oklade.net/findpath.php

In configuration.php, there is nothing specifically pointing to the old site.

var $dbtype = 'WeboMySql';
var $host = 'localhost';
share|improve this question

2 Answers 2

I'm just guessing into the blue. If you have disabled error reporting this might explain the white page. There might be an error like a missing extension that causes the page not to load.

You can check your extensions with the phpinfo() function in PHP. Just make a php document and add

<?php
phpinfo();
?>
share|improve this answer
    
Error reporting is Maximum, 6135. –  Dan Horvat Jun 20 '12 at 18:52
    
I have never used cPannel. Does it require PHP to work? I have not seen any dependencies yet so maybe PHP is not setup correctly. What Webserver do you use? –  Christopher Perrin Jun 20 '12 at 18:58
    
I don't know does cPanel require PHP to work, never seen it crash, but on my website PHP works as it loads a small PHP file. The entire configuration seems to be the same between these two servers. PHP version, Apache version, except that the new server uses XCache and Nginx. –  Dan Horvat Jun 20 '12 at 19:05

Problem is solved.

The configuration.php file was to blame, as everyone suggested, but there was no possible way to change it manually and get it right, I had to make the system determine its own configuration.

I installed a fresh version of Joomla in a separate folder, and a fresh version of PHPBB3 in a separate folder.

Then I took the configuration.php and config.php files for those two things and put them in the existing folders of the website which didn't work.

Changed the minor details such as database prefixes (as I couldn't have entered the existing ones while installing), and that's it. Now it works.

So this might be a good workaround for anyone facing the same problem. Install a dummy version of Joomla and use the generated configuration.php file for the old, non-functioning website.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.