Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

Sign up
Here's how it works:
  1. Anybody can ask a question
  2. Anybody can answer
  3. The best answers are voted up and rise to the top

I've got an IBM x346 that was (supposedly) working fine in the past which will no longer post now that I've taken it back out of storage.

When I power it up, it seems to be permanently stuck in an endless cycle of almost posting and then reseting. It doesn't get to the beep codes, but does periodically flash the boot logo momentarily on the attached monitor, and the 2x8 segment post display is in constant flux. If I remove the memory, it properly lights up the missing module indicators (by the dimm and on the lightpath), and emits the out of memory beep code. It does the same thing if I install dual-rank dimms (obviously, this machine shouldn't support that).

I've pulled all the acccessory cards and risers that can reasonably be removed, taken out the drives, and still this endless post cycle. I've tried both power supply modules. I don't have another similar machine handy, or I'd start swapping in the more important bits.

Any advice on where to look next? Anyone else seen this behavior?

share|improve this question
Just tried clearing the CMOS and reseating the CPUs. No change. – Paul McMillan Jul 13 '09 at 19:54
Might be bad memory. If it will run on just one stick (not familiar with this model), try one at a time, and try it in different slots). Also, as Izzy said, reseat everything with a socket possible. Also, blow out any dust, especially down in the empty memory slots. – kmarsh Jul 13 '09 at 20:00

Replace the CMOS backup battery and clear CMOS.

share|improve this answer
No luck with this. – Paul McMillan Jul 13 '09 at 19:59
up vote 2 down vote accepted

Further investigation has revealed that it wasn't any of those previous ideas at all.

Apparently the system will not stay powered (and thus will not boot) if the POWER cable connecting the PSU to the SCSI backplane is not fully and completely seated. It had worked its way loose, and seems to have been the root cause of the problem. The data cable can be completely absent without problems.

share|improve this answer

Have you tried reseating the CPU(s)?

share|improve this answer
This didn't seem to change anything. – Paul McMillan Jul 13 '09 at 19:59

Your Answer


By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.