Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

When I try to run

yum install php-mssql

I get the following error

--> Processing Conflict: mysql conflicts MySQL
--> Processing Conflict: mysql-server conflicts MySQL-server
--> Finished Dependency Resolution mysql-5.0.45-7.el5.x86_64 from installed has depsolving problems   --> mysql conflicts with mysql mysql-server-5.0.45-7.el5.x86_64 from installed has depsolving problems   --> mysql-server conflicts with mysql-server Error: mysql conflicts with mysql Error: mysql-server conflicts with mysql-server  You could try using --skip-broken to work around the problem  You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest

It starts with

Loaded plugins: fastestmirror
Loading mirror speeds from cached hostfile
 * atomic: www7.atomicorp.com
 * epel: mirror.fraunhofer.de

When I run

package-cleanup --dupes | grep mysql

mysql-server-5.0.90-1.el5.art.x86_64
mysql-server-5.0.45-7.el5.x86_64
mysql-5.0.90-1.el5.art.x86_64
mysql-5.0.45-7.el5.x86_64

I am trying to install the mssql package but it looks like there is a problem with mysql? Can I uninstall mysql-server-5.0.45-7.el5.x86_64 and mysql-5.0.45-7.el5.x86_64?

Please advice.

share|improve this question

3 Answers 3

up vote 0 down vote accepted

The problem is your have a non-centos version of MySQL installed and it is complaining about that conflict.

rpm -qa | grep MySQL

See if you have that installed also. along with @Quinn's post

share|improve this answer
    
Thanks Mike, I get two packages trying your command, what do you suggest? perl-DBD-MySQL-3.0007-1.fc6 and perl-DBD-MySQL-3.0007-2.el5 –  Pasta Jun 21 '12 at 12:53

The message makes it seem like 5.0.90 was pre-installed, and the problem is getting that older version on. Regardless, you can remove the packages like so:

rpm -ev mysql-server-5.0.45-7.el5.x86_64
rpm -ev mysql-5.0.45-7.el5.x86_64

You should be able to run the install after that.

share|improve this answer
    
I think that is part of the issue –  Mike Jun 21 '12 at 12:43
    
I tried yum remove mysql-5.0.45-7.el5.x86_64, it removed both the packages, now I don't have the dependency issue, it is something else, we are getting closer, thanks for your help. –  Pasta Jun 21 '12 at 12:45
    
did you try the yum package-cleanup --problems? What did it return? Also, it might be useful to edit your main questions with the dvelopments so it is easier to track. –  Quinn Murphy Jun 21 '12 at 13:34

Quinn was helpful, I tried

yum remove mysql-5.0.45-7.el5.x86_64

It removed both the packages. Now when I try

yum install php-mssql

---> Package mysql-server.x86_64 0:5.5.25-7.el5.art set to be updated
--> Processing Dependency: mysql = 5.5.25-7.el5.art for package: mysql-server
Error: No Package Matching 
 You could try using --skip-broken to work around the problem
 You could try running: package-cleanup --problems
                        package-cleanup --dupes
                        rpm -Va --nofiles --nodigest
share|improve this answer
1  
did you try a yum update before the yum install? –  Mike Jun 21 '12 at 12:58
    
Excellent, that's all it needed! –  Pasta Jun 21 '12 at 13:34

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.