Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I have setup SSRS2008 on a server in DOMAIN1. Users and groups from DOMAIN1 currently can access reports as expected and in accordance to their site, folder and report permissions. This was working well for a month.

Now, I have to allow users from DOMAIN2. DOMAIN2 and DOMAIN1 are in a trust relationship. I can list DOMAIN2 users and groups in the security tabs, but they cannot get into the site, even at the top level.

The error is: User 'DOMAIN2\user' does not have required permissions. Verify that sufficient permissions have been granted and Windows User Account Control (UAC) restrictions have been addressed.

Searching Google is useless as the dominant solution addresses the first time access problem, where using IE as administrator gets you into the site and able to start listing the first users and groups. That is not my issue. I currently do have users accessing reports, just not those in DOMAIN2.

Any help is appreciated.

share|improve this question
    
As with all problems with Domain Trusts, more information is needed from you. What type of Trust? What Trust authentication is being used? –  joeqwerty Jun 21 '12 at 14:22
    
It looks good, maybe you forgot to add ACL on the file? It should really work. –  Andrew Smith Jun 21 '12 at 15:54
    
I just came with the same issue, know it's a bit late, but do you by chance remember if this problem solved and what was the issue in your case? –  Afshin Sep 26 '13 at 23:56

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Browse other questions tagged or ask your own question.