Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to grant read and write permissions to the system Temp location to the IIS_IUSRS group. There is a system variable declared %TEMP%; but unfortunately there is also a user variable by the same name.

As a result, when I run the command

C:\Program Files\IIS\Microsoft Web Deploy V2>msdeploy -verb:sync -source:setacl -dest:setacl=%TEMP%,setAclUser="IIS_IUSRS",setAclAccess=Write

the IIS_IUSRS group is granted write permissions defined in the user's %TEMP% location, and not the system %Temp% location.

One solution I explored was to reference the temp directory at %windir%\TEMP, but there's a good chance that the system %TEMP% variable that IIS references will not be set to that location in all instances and therefore isn't applicable on this occasion.

Has anyone tried to do this previously, or think of a method of referencing the system variables rather than the user variables?

share|improve this question

1 Answer 1

"C:\Program Files (x86)\IIS\Microsoft Web Deploy V3\msdeploy.exe" -verb:sync -source:setacl -dest:setacl="%windir%\temp",setAclUser=IIS_IUSRS,setAclAccess="Read,Write,Modify"

should work.

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.