Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I am trying to set up a SQL Server practice lab using VirtualBox and a trial copy of Windows Server 2K8 R2 in ISO format. I received an error message that states my processor does not support 64-bit hardware virtualization. Although I "Enabled" Intel ardware virtualization in the BIOS that still doesn't work. According to the Intel website, the processor does support VT-x, however the accelerated tab in VirtualBox is greyed out and no references to VT-x are mentioned in the settings options available to me.

Any ideas on how I can get around this?

I checked around ServerFault and couldn't find anything but if I missed an applicable post a link is great too. Specs below - if additional information is needed please comment and I will provide. Thanks in advance.

VirtualBox version - 4.1.18 Hardware - Lenovo B570 1068-A3U i3-2310M

share|improve this question
add comment

3 Answers

Probably while creating the new virtual computer you did not select Windows7 64bit. Create a new one and make sure that you have selected Windows 7(64 bit) from the drop down box.By default if you write windows 7 for name in version brings windows 7 (not 64bit). VirtualBox 64-bit guests

share|improve this answer
add comment

On some BIOSes, you not only need to enable hardware virtualization, but also the "execute disable bit", or whatever it's called in that specific BIOS; without it, some hypervisors just won't work.

share|improve this answer
add comment

this is an old question to which I am answering. I am having a similar issue using VirtualBox on Windows 8 pro (64bit).

In my case I had to "Disable" Execute Disable bit to make the Hardware Acceleration work. My MB manufacturer is ASUS and I have logged an inquiry to the issue too. I still havent found a way to make both Intel Virtualization and Execute Disable bit to work together.

I will keep the post updated so that someone searching can find it useful.

share|improve this answer
    
I had the same issue with the Acceleration tab being grayed out in VirtualBox with my ASUS Rampage GENE II motherboard. As soon as I set the Execute Disable to Disable in the BIOS, the tab became available. I hope this helps someone else. –  Art Jan 18 at 21:10
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.