Take the 2-minute tour ×
Server Fault is a question and answer site for system and network administrators. It's 100% free, no registration required.

When I add option userquota,groupquota to the main (/) partition of my Debian 6 DirectAdmin server, it mounts that partition in read-only mode.

Wat I did:

  1. nano /etc/fstab
  2. add userquota,groupquota after errors=continue in the 'options' column to the / mount-point
  3. save the file and exit nano
  4. reboot the server

On reboot it shows a lot of errors, all related to read-only filesystem.

Doen someone know what I perhaps did wrong? Thanks a lot!

Edit: my fstab looks like:

# /etc/fstab: static file system information.
#
# Use 'blkid' to print the universally unique identifier for a
# device; this may be used with UUID= as a more robust way to name devices
# that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point>   <type>  <options>       <dump>  <pass>
proc            /proc           proc    defaults        0       0
# / was on /dev/vda1 during installation
UUID=aca09b50-554b-45b6-b3b6-e4444f1f80b6 /               ext3    errors=continue,userquota,groupquota 0       1
# swap was on /dev/vda5 during installation
UUID=628fb534-f3e4-4c44-93ad-f9f7992feff6 none            swap    sw              0       0
/dev/scd0       /media/cdrom0   udf,iso9660 user,noauto     0       0
share

locked by HopelessN00b Apr 3 at 18:14

This question exists because it has historical significance, but it is not considered a good, on-topic question for this site, so please do not use it as evidence that you can ask similar questions here. This question and its answers are frozen and cannot be changed. More info: help center.

closed as off-topic by HopelessN00b Apr 3 at 18:14

  • This question does not appear to be about server, networking, or related infrastructure administration within the scope defined in the help center.
If this question can be reworded to fit the rules in the help center, please edit the question.

1 Answer 1

up vote 1 down vote accepted

The correct options are usrquota and grpquota. Also, after enabling quotas, you should run quotacheck -uvg /path/to/your/device in order to create the aquota.{user,group} files.

However, I would suggest to set up journalled quota as described in this tutorial.

share
    
Do you know if that works with DirectAdmin? –  George Boot Jun 22 '12 at 10:47
    
Journaled quota? Yes, it works. –  Vladimir Blaskov Jun 22 '12 at 10:58

Not the answer you're looking for? Browse other questions tagged or ask your own question.