Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I've got a Win 2K3 server that is hosted in a data centre hence all administration is done via RDP.

The last couple of times I've re-started it after patching the server hangs - on the way down from the looks of it as IIS & SQL are still publicly responsive but my access to RDP goes straight away. The server will sit in this state indefinitely and it needs me to get a data centre engineer to do a cold boot on it as they can't get console access to it locally either.

The event logs simply state that my restart failed with another log entry suggesting an application pop up appeared warning that the machine would not be available until it was started locally?

What could be causing this - I know 3rd party apps sometimes don't play nice with the shut down command but there's no evidence in the logs as to which app is the problem and the advice from the MS knowledge base is to remove apps 1 by 1, restarting each time until the problem is fixed! This is a live server so I don't have that luxury.

Are there any settings I could look at that may have fired the pop-up message and does anyone have any good suggestions for spotting the underlying cause without me needing to go for the MS approach of pull remove apps at random?

Log Entries:

22:15:20 - ID 1074 - The process Explorer.exe has initiated the shutdown of computer... for the following reason: Other (Planned)

22:15:20 - ID 26 - Application popup: Windows: If you shut down this remote computer, no one can use it until someone at the remote location manually restarts it? Do you want to continue shutting down?

22:15:22 - ID 1073 - The attempt by user username to restart/shutdown computer server failed

22:15:41 - ID 1074 - The process Explorer.exe has initiated the shutdown of computer... for the following reason: Other (Planned)

22:15:45 - ID 1074 - The process svchost.exe has initiated the shutdown of computer... for the following reason: No title or reason could be found

share|improve this question
    
Can you post the log file entries? –  Adam Brand Jul 13 '09 at 20:45
add comment

4 Answers

up vote 2 down vote accepted

Is anyone logged interactively e.g. via VNC or an autologin? I've seen this occasionally when something hangs in the interactive session. Typically this happens after the VNC and TS servers have shutdown, so there's no way to get in and kick the server! These days I insist all my servers have a DRAC card (on an HP use the iLO card) so I can hard reset them remotely if I have to.

JR

Does this help:

http://support.microsoft.com/kb/930045

A way to test this would be to create a scheduled task to restart the server in (e.g.) 5 minutes then log out. That way there is not terminal servivce session active when the restart happens. If the restart now works normally the above may well be the reason.

share|improve this answer
    
Nothing like that is running on them. I'd normally have the iLO set-up but this is a server sat in a data centre so I'm stuck with their default kit. –  Chris W Jul 14 '09 at 8:14
    
I've added some notes above. –  John Rennie Jul 14 '09 at 8:40
    
That's an interesting article - I'll certainly give that a try in the next maintenance window. –  Chris W Jul 14 '09 at 12:29
add comment

Add VNC or logmein since they give you console access (add both why not) and you might see what is happening.

Also take a look at Wizmo from GRC its a little general purpose utility that can do a shutdown/restart from the command line. On troublesome machines I've see it work better then the windows shutdown command.

share|improve this answer
add comment

You could stop IIS and SQL server as well as your apps before restarting. If doing that gets you a clean restart then you know it's one of them and figuring out one is a process of elimination.

I would try verifying if they're just trying RDP locally or if they're actually trying with KVM or a local keyboard/mouse/monitor. If they're just trying RDP it's no wonder at all that they aren't getting any further than you are.

share|improve this answer
add comment

One of the patches released in June caused this problem on a lot of our servers, especially clustered SQL and Citrix (about 30/500+).

Have you tried a restart from the command prompt?

shutdown -f -r -t 10

EDIT:

Also, can you edit your question and paste the last sections of the shutdown log?

\WINDOWS\system32\LogFiles\Shutdown

share|improve this answer
    
This has happened the last 3 times the server has been re-started over the last 3 months so it's not a recent patch that's causing it but I will try the command line when I next get a maintenance window. –  Chris W Jul 13 '09 at 21:04
    
Edited answer with a request for more info –  Izzy Jul 13 '09 at 21:08
    
There's nothing in the path you mention. –  Chris W Jul 14 '09 at 8:15
add comment

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.