Take the 2-minute tour ×
Server Fault is a question and answer site for professional system and network administrators. It's 100% free, no registration required.

I'm trying to enable e-mail alerts for an operator in SQL Server (2000). When I try to test the e-mail, I get the following message:

  • Error 22022: SQLServerAgent Error: The SQLServerAgent mail session is not running; check the mail profile and/or the SQLServerAgent service startup account in the SQLServerAgent Properties dialog.

When I open [Server].Management.[SQL Server Agent] in Enterprise Manager, The only option that seems at all relevant is the "Mail Session" section; but the "Mail Profile" field (and everything else in the box) has been grayed out.

How do I get those fields enabled?

share|improve this question

2 Answers 2

up vote 4 down vote accepted

You need to install Outlook on the server, log on as the account you use to run SQL server under and configure Outlook.

See also, KB311231.

share|improve this answer

Right-click on the server, click on Properties, then verify that your mail profile shows up on the Server Settings tab.

More info here: http://www.databasejournal.com/features/mssql/article.php/10894_3345091_4/SQL-MAIL-and-SQL-Agent-Mail-using-POP3-and-SMTP.htm

share|improve this answer

Your Answer

 
discard

By posting your answer, you agree to the privacy policy and terms of service.

Not the answer you're looking for? Browse other questions tagged or ask your own question.